Forum Replies Created

Viewing 15 posts - 1 through 15 (of 26 total)
  • Author
    Posts
  • #37615
    Profile photo of Greg
    Greg
    Participant

    Just an update that we are currently in the process of doing a lot of testing and upgrading to ensure that Symbiostock is compatible with all the new versions of WooCommerce etc. We should have an upgraded release relatively soon.

    When you say all new versions, does that mean it will keep up to date with ongoing WooCommerce updates? Or will it be stuck to the first WooCommerce v 4.0.1 only? Current WooCommerce for example is v4.5.2.

    If stuck on v4.0.1, what plans, if any, are there to catch up with WooCommerce continued updates?

    #36768
    Profile photo of Greg
    Greg
    Participant

    Sorry, jumped the gun, I found the setting Personalize Product Page > Add media information to product page.
    Cheers

    #36700
    Profile photo of Greg
    Greg
    Participant

    This has self corrected, I now have 4.1.1

    Thanks

    #36050
    Profile photo of Greg
    Greg
    Participant

    Hmm, Ok I see the issue, I am sorry, I tested all other plugins just not the one that is causing it to not work, which is WPC Variations Radio Buttons for WooCommerce. Not sure why I missed it, but I thought I did test that.

    (this is VERY annoying having to wait so long to reply post as i am going too fast … ERROR: Slow down; you move too fast. )

    (i’m also not using the Express theme)

    #36048
    Profile photo of Greg
    Greg
    Participant

    Yes and tried on different browsers

    #36046
    Profile photo of Greg
    Greg
    Participant

    How do I set this as not resolved?
    Surely as the poster I should mark it as resolved?
    You have just assumed it is resolved before checking?

    #36038
    Profile photo of Greg
    Greg
    Participant

    Yes I have already done that as well.

    licence sorting

    #36030
    Profile photo of Greg
    Greg
    Participant

    OK found it and have changed it. If anyone else is interested

    wp-content/plugins/woocommerce/templates/order/order-downloads.php

    Change this (line 53)

    echo '<a href="' . esc_url( $download['download_url'] ) . '" class="woocommerce-MyAccount-downloads-file button alt">' . esc_html( $download['download_name'] ) . '</a>';

    to this and then save it in your (child) theme woocommerce/order/ folder with the same name

    echo '<a href="' . esc_url( $download['download_url'] ) . '" class="woocommerce-MyAccount-downloads-file button alt">Download</a>';

    Now the buttons say Download

    Changed

    Cheers

    #36029
    Profile photo of Greg
    Greg
    Participant

    I’m still not sure what you understand to be my question/request. Probably because I am not explaining myself properly 🙂

    I’m not wanting to change the actual file name at all.

    What I am wanting to do is change the link name to the file,

    Email Example

    Website Example

    Cheers

    #36025
    Profile photo of Greg
    Greg
    Participant

    I think you mean the name of the downloaded file itself? I am talking about the file name displayed on the website account download page, e.g. ef7e28.media. I’d like to change this to just ‘download’ but it still retain the correct link to download the ef7e28.media file. It is simply tidier and clean fro the customer to see.

    Cheers

    #35935
    Profile photo of Greg
    Greg
    Participant

    My need for the update is for the use of other woocommerce extensions.

    #35863
    Profile photo of Greg
    Greg
    Participant

    Use PHP 7.0.x

    #35827
    Profile photo of Greg
    Greg
    Participant

    Not sure if this works for jpegs uploaded via FTP for SymbioStock to process, but I have previously used this function to ensure no loss with jpegs during normal jpeg uploads in WP.

    // Zero Image Compression Setting //
    
    add_filter( 'jpeg_quality', 'stock_photography_custom_jpeg_quality' );
    function stock_photography_custom_jpeg_quality( $quality ) {
      return 100;
    }

    Put in your functions.php file and see if that helps

    #35399
    Profile photo of Greg
    Greg
    Participant

    Thanks for the reply

    I am able to get it to process 1 image per minute, is it meant to be like that or shoudl it process all at once?

    My cron email result when 1 image is processed every minute

    HTTP/1.1 200 OK
    Date: Tue, 29 Oct 2019 01:12:01 GMT
    Server: Apache/2
    X-Powered-By: PHP/7.0.33
    Expires: Thu, 19 Nov 1981 08:52:00 GMT
    Cache-Control: no-store, no-cache, must-revalidate
    Pragma: no-cache
    Set-Cookie: PHPSESSID=2j3hkrio7o8g8f2t34nb3ev1e1; path=/
    Upgrade: h2,h2c
    Connection: Upgrade
    Vary: Accept-Encoding,User-Agent
    Cache-Control: public, no-transform, must-revalidate
    Last-modified: Tue, 19 November 2017
    Transfer-Encoding: chunked
    Content-Type: text/html; charset=UTF-8

    <html>
    <head>
    <meta http-equiv=”cache-control” content=”max-age=0″ /> <meta http-equiv=”cache-control” content=”no-cache” /> <meta http-equiv=”expires” content=”0″ /> <meta http-equiv=”expires” content=”Tue, 01 Jan 1980 1:00:00 GMT” /> <meta http-equiv=”pragma” content=”no-cache” /> <style> .memcl { display:inline-block; padding:10px 20px; border:1px solid gray; margin:10px 20px; } .actio { display:inline-block; padding:10px 20px; border:1px solid blue; margin:10px 20px; } </style> </head>

    Memory at Start: 52M
    Load at Start: 1M
    1 new/updated images/videos parsed
    0 thumbnails re/generated
    Memory at End: 53M
    Memory Peak: 53M
    Load at End: 0M

    <hr>

    Does that help?

    #35328
    Profile photo of Greg
    Greg
    Participant

    Anyone able to assist?

    I have tested Imagick

    Version: ImageMagick 7.0.8-46 Q16 x86_64 2019-08-18 https://imagemagick.org
    Copyright: © 1999-2019 ImageMagick Studio LLC
    License: https://imagemagick.org/script/license.php
    Features: Cipher DPC HDRI OpenMP(3.1)
    Delegates (built-in): bzlib freetype jng jpeg png webp xml zlib

    I was using php 7.2.x, but have changed that to 7.0.x but it is still not helping

    Please, does anyone have a solution for this?

Viewing 15 posts - 1 through 15 (of 26 total)