Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #33896
    Profile photo of Theresa Sheridan
    Theresa Sheridan
    Participant

    I do not have cPanel or Plesk, rather my site is on a NGINX server, so I have installed the Advanced Cron Manager plugin to handle this. I’ve set up the task to run every minute (at least I think I have), but it doesn’t appear to be running. I copied and pasted the command provided in your plugin, and set it to run every minute, but it’s not processing the images I’ve uploaded until I run it manually. Your plugin IS processing my images, so somehow I just don’t have the scheduling set up correctly.

    Can someone help me figure this out please?

    #33904
    Profile photo of Robin
    Robin
    Keymaster

    Hi Theresa,

    You cannot use a WordPress plugin for the cron as the processor will not complete properly randomly that way. The best way is to use a third party trigger if your control panel does not support it, such as:

    https://cron-job.org/en/

    #33916
    Profile photo of Theresa Sheridan
    Theresa Sheridan
    Participant

    Thank you for the information. I’m trying to set this up, but I can’t figure out how it works, and where/how I enter the command that you provide in the System settings.

    • What is the Request Method? It seems the only options that allow me to enter the command you provide would be PUT or POST.

    • Do I need to check the box for HTTP authentication and put my WP credentials here for this to run properly? (My hosting company is using NGNIX servers and they do not use .htaccess files)

    I have using both the POST and PUT methods, with and without HTTP authentication, but it keeps failing, or says it’s inactive, so clearly I’m doing something wrong.

    Since my website is running on an NGNIX server, I do not have a cPanel or Plesk to schedule this on the server and would appreciate any help you can provide. Thank you 😊

    #33919
    Profile photo of Robin
    Robin
    Keymaster

    Hi there – it should be very easy.

    Sign up, click on cronjobs, and click create cronjob.

    Then under address put in the URL portion of the command found in your Symbiostock > Settings > System tab. It will start with https and end with some random characters.

    Do not enable HTTP authentication, Schedule it to every minute, and click save. It should be done.

    #33921
    Profile photo of Theresa Sheridan
    Theresa Sheridan
    Participant

    So I had put the URL of my website in that field, because the commend that is in the plugin instructions under Settings is this –

    curl -silent -A ‘Mozilla’ ‘https://www.theresasheridan.com/?c=1&ss_c=134f33d9a3182de5d5fa’ >/dev/null 2>&1

    and it won’t even save the cron job this way.

    I knew it wanted the command to begin with https, that’s why I was confused and asking for instructions.

    I’ve also tried adding my website URL before the command, and I’ve tried removing the portion before the URL in the command, but neither method works.

    Is the command wrong? If so, please provide me the correct one so that I can get this up and running. Thank you.

    #33923
    Profile photo of Robin
    Robin
    Keymaster

    Hi there – it is the URL portion within the quotes:

    https://www.theresasheridan.com/?c=1&ss_c=134f33d9a3182de5d5fa

    However, I would recommend, since this has been publicized, that you click on “reset cron code”, then submit, then refresh the page, then cut and paste the url with the new secret code into the cron job website.

    #33925
    Profile photo of Theresa Sheridan
    Theresa Sheridan
    Participant

    Yes, thank you, thank worked!!!! I sure appreciate the help 🙂

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.