Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #26031

    One customer placed a purchase just now and emailed me saying the file following download link is empty (0 bytes).  I test run on my site with couple of images. Whenever the image is panoramic the downloaded file is empty. For single image it works fine.

    I also tried the download in symbiostock’s media editing page and the download works fine. Thanks for any help!

    #26032

    Update: tried another panoramic with smaller file size 8.65M it works file. The one failed has file size of 36.1M. Hopefully some clues with trouble shooting. Thanks for any help.

    #26033
    Profile photo of George Sheldon
    George Sheldon
    Participant

    There is a nationwide problem right now on the networks with the Level 3 Servers (I just got off the phone because I am getting 504 Server Timeout Errors when I run the CRON job).  Not sure if this is related to your issue, but perhaps large files are not being handed off among the servers right now.

    #26034

    Thank you George for the info. If it’s server’s temporary hiccup that’s fine otherwise it is a big issue as most of my files are 20, 30M+. Some panoramic files are as large as 50, 60M+.

    #26035
    Profile photo of George Sheldon
    George Sheldon
    Participant

    Large files like yours might not be getting through – just a thought before you push the panic button.  Here is the error I am getting:

    504 Gateway Time-out

    The server didn’t respond in time.

    #26036

    Files are downloaded in a flash of light but they are 0 byte file in local hard drive. No error message generated.

    As I can successfully download those files in media editing page, I doubt it is the temporary server outage.

     

    #26037
    Profile photo of George Sheldon
    George Sheldon
    Participant

    It was just a thought – your client might be at a different point where the large file is sliced and diced and reassembled (that packet thing) and it can’t reassemble correctly because not all of the packets are arriving via the Internet at your client’s computer.

    Just wanted you to know of the large Internet server issue going on right now. I hope whatever your problem really is, you are able to resolve it.

    #26038

    Thanks George, you provided a lot of good information. I really appreciate your kindness and help.

    The issue is not resolved yet. Hopefully Robin or someone understand the core of symbiostock may chime in. I really need to resolve this issue as the site is runing with very good sales trend.

    #26039
    Profile photo of Robin
    Robin
    Keymaster

    Hey Songquan,

    This is an issue that will be PHP, Apache, or server related. Please PM me your login info and I’ll see if I can replicate the issue on my side. If I cannot, then it is a resources problem. This is very likely since it is a size related issue. I’ve not tested files that huge before with regards to images.

    #26040
    Profile photo of Robin
    Robin
    Keymaster

    One quick solution you can do is create a license for the super large images and ensure that you don’t have ‘strip meta tags’ enabled in your Symbiostock settings. On the license page for this, make it so it filters only for very high resolutions, and ensure that ‘sell unaltered’ is clicked.

    What this will do is remove any PHP processing of the media and just provide the original to the customer.

    However, to be honest, if your thumbnails got created, there shouldn’t be a resource issue. So the best we can do is you send me your login info and I’ll dig around.

    #26041

    Thank you Robin, Login info sent. Appreciate your help!

    #26045
    Profile photo of Robin
    Robin
    Keymaster

    K, so the solution for this for now is:

    Ensure that ‘strip image metadata’ is disabled in your Symbiostock Settings. Basically, when you are stripping the metadata PHP has to process your massive image and then serve it up via PHP. This may be too much load for some servers if your image is really large.

    We’ll try to tweak this in the next release so that doesn’t happen, but for now is an easy viable solution for those of you with like 30 megapixel images.

    FYI, I uploaded the same image to our server and it did not experience the same issue. It is therefore a server specific limitation, likely relating to memory.

    #26046

    Thanks Robin! I tested and it works perfectly. Appreciate very much your hard work while I was sleeping. 😛

    #26047

    And thank you George. Whenever we have questions you are always there. 🙂

     

Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.