Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #36996
    Profile photo of Tony

    Hi Robin,

    I am preparing to install Symbiostock on an EC2 instance at Amazon AWS. It is an Amazon Linux server with Apache and PHP 7.2 installed.

    There are also:
    – ImageMagick.x86_64 v6.7.8-9 (2020-02-13),
    – php-pecl-imagick.x86_64 v3.4.4-1.amzn2.0.1.

    If I enter php -m, I see that imagick extension is installed.

    However, phpinfo() does not show any information about imagick extension.
    I also tried to run a test PHP code which tries to create an image, but got an error message – “Class ‘Imagick’ not found”.

    What am I doing wrong?

    Profile photo of Tony

    I have already solved the problem.

    Having looked at the *.so files (PHP extensions) in /usr/lib64/php/modules/, I noticed that access rights for them all except were 755, and had 644. That is, nobody was allowed to run this file.

    I changed the access rights for to 755, then restarted httpd and php:
    sudo service httpd restart
    sudo service php-fpm restart

    After that, imagick started working and appeared in phpinfo() extensions list.

    Profile photo of Robin

    Thanks for sharing your resolution, Tony.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.