Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #27813
    Profile photo of joel
    joel
    Participant

    On the symbiostock settings, now I don’t see  the place to choice the number of images for the cron job,  the cron job work for only one picture (before cron work for my choice of 20 pictures) !

    #27858
    Profile photo of Chrisroll
    Chrisroll
    Participant

    Hi, Joel,

    I saw that too…
    I recently sold 20 images and as images are only processed once the orders are completed the customer received the download link more than 30 minutes later. It would be nice if we could choose again the number of images proceesed by the cron job, but Perhaps there’s a technical reason to explain this limitation.
    Robin, will it be possible to restore this option?

    #27863
    Profile photo of joel
    joel
    Participant

    For me it’s not a problem with the sales process, it’s a problem for image processing (after sending by ftp) : thumbnail creation and application of a watermark. Before I could choose to process 20 images, now I do not see the choice of the number of images to be processed, there is only one image that is treated when I run the cron job!

    #27867
    Profile photo of Robin
    Robin
    Keymaster

    Hi guys,

    We were getting a lot of issues with this setting due to people getting server problems with it.

    With the next update we will add a filter so you can add it to your theme’s functions.php so you can always keep this at a different number. However, for now, if you want, go into tools-cron.php and edit the ‘maxload=1’ line and change the 1 to 20 or so.

    Once Symbiostock updates to the new version this will get overwritten but then there will be a new filter added so you can just do it as previously mentioned. When/if you decide to that after the next update, just let me know and I’ll show you the syntax.

    #27868
    Profile photo of Robin
    Robin
    Keymaster

    You should not be manually running the cron job regardless – it should be in your control panel set on a one minute timer.

    #27875
    Profile photo of joel
    joel
    Participant

    I edited the file tools-cron.php  line 71 : $maxload = 1;
    $maxload = 20;
    It works! Thank you !

    #27877
    Profile photo of Chrisroll
    Chrisroll
    Participant
Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.