Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #304
    Profile photo of Anonymous

    I’m at a loss as to why things are behaving the way they are and am hoping someone with more WordPress experience can point me somewhere with information on how to fix things.

    My site looks OK visually but file downloading (for paid for files) has broken – I just get a blank white page. I am not running PHP 5.4 – see a list of what my Bluehost site is running:

    Apache version 2.2.25
    PHP version 5.3.27
    MySQL version 5.5.33-log
    Architecture x86_64
    Operating system linux
    Shared IP Address
    Kernel version 2.6.32-20130307.60.9.bh6.x86_64

    Searching for others with the blank page problem suggested it was always the PHP version in the past.

    I’ve cleared the browser cache (Chrome) and tried Safari and Firefox (all behave the same).

    You can log in with a test account that has purchases to see the problem –

    user: TryOut
    pwd: pleaseenjoymysite (that’s please enjoy my site without the spaces!)

    If you look at the page (logged in), you’ll notice the download buttons have extra information

    That’s my second mystery. I had edited code to make those changes, but tried to back everything out and go to a plain vanilla 2.6.5 Symbiostock installation. I think I did that – and my changes are no longer in the php files on the site.

    But they still show up! I don’t understand how this can be unless there is somewhere on the server that’s caching an old version. With my re-install of 2.6.5, all my theme files have dates newer than anything I edited.

    It may be that my code changes had nothing to do with file download not working (I had tested it after I first made the button changes and download worked), but at this point I’m just trying to back things out to return to a functional state.

    I did disable SYXtra to see if that made a difference – it didn’t.

    I don’t have any WordPress caching plugin

    I’ve searched on these topics but they all seem to relate to browser cache or WordPress caching plugins.

    Any clues?

    Profile photo of ajt

    1. Earlier error (that with ajt_ and & character) was specific to php 5.4

    To be sure, what php version you have, create file with

    < ?php

    and put it in root folder. Then call your_site/info.php

    2. If buttons have extra info, there are still php file you edited…

    Profile photo of JoAnnSnover

    Thank you.

    Here’s what that file shows – which is NOT what Bluehost’s cPanel is telling me (and isn’t what I picked when I changed from 5.2.x to 5.3.x a few weeks back)

    I don’t quite understand why or how Bluehost would be showing me something that wasn’t accurate. I’ll look into how to get that changed back.

    As far as the php files being there – I reinstalled everything after deleting my edited files from the site. I use Fetch for FTP and it has a quick look feature to look at files from the remote site and my code isn’t in the files that are on the site…

    I know it sounds nuts 🙂

    I may have to talk with Bluehost support

    Profile photo of JoAnnSnover

    So when I went to PHP Config in Bluehost’s cPanel, it showed me the version was 5.4 – I guess you cannot rely on the information shown in the panel on the lower left of the main cPanel page.

    I also don’t like it that they just upgraded things without my knowledge – no e-mail no warning…

    I swear I have not touched PHP Config since I changed it to 5.3 a few weeks ago.

    So FWIW, here’s the before and afterdisplays from the phpinfo() call (I’ll leave info.php in my root folder for future reference)

    I guess Bluehost hosted sites need to keep an eye on unwanted configuration changes if things start not working on their site.

    I haven’t solved my mystery edits problem, but as I only backed the changes out because a couple of things weren’t working (which was probably something to do with the PHP changes) I think I’ll go put the edits back and be happy 🙂

    Thanks again for the assistance.

    Profile photo of sharpshot

    I had the same thing happen with Bluehost. I was away from home and hadn’t changed anything. Hope there’s a way to stop this happening again.

    Profile photo of JoAnnSnover

    @sharpshot wrote:

    I had the same thing happen with Bluehost. I was away from home and hadn’t changed anything. Hope there’s a way to stop this happening again.

    I didn’t call Bluehost to complain or get an explanation – so possibly there is some more to this than meets the eye. What meets the eye is that they may change material things on the server without notifying users.

    The really damaging thing, from my point of view, is that the cPanel said 5.3.27 which led me on a wild goose chase looking for another cause.

    Now, at the first sign of trouble I will run the info.php file to see what’s actually there…

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.