A free, full featured WordPress plugin to sell your photographs, images & vectors online
Looking for stock photos?

Complete / Processing Problem

Home Forums Symbiostock Support Using Symbiostock Complete / Processing Problem

This topic contains 1 reply, has 2 voices, and was last updated by Profile photo of Dawn Dawn 1 week, 1 day ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #29924

    There is a advise on the top of the Order page of woocommerce:
    “Note that Symbiostock orders should never be manually set to ‘Complete’ – always set them to ‘Processing’ and let the processor then prepare the media and update the order when ready. If you set it to ‘Complete’, customers will receive download links that may not work. You may also re-process an order by setting it to ‘Processing’ anytime.”
    But, if I press processing the processing never ends and the client never can download the images. What I should do?

     

    #29933
    Profile photo of Dawn
    Dawn
    Keymaster

    Hi Rodrigo,

    That message is correct, you should never manually set your Symbiostock order to Complete, you have to let the Symbiostock processor (cron job) do that. Once you have set an order to ‘Processing’ the next time your cron runs, it will process the order and update it to ‘Complete’. If your cron is not running, then it won’t update, that you might have to look into whether you have set that up properly. You can read about that in this guide:

    https://www.symbiostock.org/docs/setting-up-the-schedulerimage-processor/

     

    For now, you can manually run the cron by going to Symbiostock > Settings > System > Symbiostock Processor (cron job) (Run now) -> Click on the Run Now link.

    That will run your cron once. Do this then go and refresh your woocommerce orders page, your order should be updated. Manually running the processor on a long term basis will not work, so make sure check whether you have set up the automatic processor properly.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.