Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #31146
    Profile photo of Chrisroll
    Chrisroll
    Participant

    Hi Robin,

    I’ve a PHP error on my logs when symbiostock plugin checks for update :

    [02-Aug-2017 23:00:24 UTC] PHP Fatal error: Uncaught Error: Cannot use object of type WP_Error as array in /—/—/public_html/wp-content/plugins/symbiostock-pro/plugin_update_check.php:236
    Stack trace:
    #0 /—/—/public_html/wp-content/plugins/symbiostock-pro/plugin_update_check.php(280): PluginUpdateChecker_2_0->requestInfo(Array)
    #1 /—/—/public_html/wp-content/plugins/symbiostock-pro/plugin_update_check.php(373): PluginUpdateChecker_2_0->requestUpdate()
    #2 /—/—/public_html/wp-content/plugins/symbiostock-pro/plugin_update_check.php(431): PluginUpdateChecker_2_0->checkForUpdates()
    #3 /—/—/public_html/wp-includes/class-wp-hook.php(298): PluginUpdateChecker_2_0->maybeCheckForUpdates()
    #4 /—/—/public_html/wp-includes/class-wp-hook.php(323): WP_Hook->apply_filters(”, Array)
    #5 /—/—/public_html/wp-includes/plugin.php(515): WP_Hook->do_action(Array)
    #6 /—/—/public_html/wp-cron.php(117): do_action_ref_array(‘check_plugin_up…’, Array)
    #7 {main}
    thrown in /—/—/public_html/wp-content/plugins/symbiostock-pro/plugin_update_check.php on line 236

    Any idea ?
    Thanks for your help !

    Chris

    #31149
    Profile photo of Robin
    Robin
    Keymaster

    Hey Chris – can you give me details about your system? I’ve tried reproducing the error but cannot create it. I am running Pro 4.0.1.

    #31151
    Profile photo of Chrisroll
    Chrisroll
    Participant

    I’m running Pro 4.0.1 Pro too with Woocommerce 3.0.7, PHP 7.0.12 and MySql5.6.32.
    This error appears 4-5 times a month on my logs.

    Thanks !

    #31152
    Profile photo of Robin
    Robin
    Keymaster

    Oh, okay – but it doesn’t happen all the time? When you click on check for updates does it happen?

    #31153
    Profile photo of Chrisroll
    Chrisroll
    Participant

    No I’ve already tryed and it doesn’t…
    it seems to be an erratic error … so, difficult to solve 🙂

    #31181
    Profile photo of Robin
    Robin
    Keymaster

    As long as your WP backend doesn’t crash, I’m not going to fuss about it. This log reflects either an AJAX or background task and who knows why that may be bugging up. Thanks for mentioning it though.

    #31183
    Profile photo of Chrisroll
    Chrisroll
    Participant

    Hi Robin,

    Ok and Thanks for your answer.

    Chris

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.